• Philippe Pepiot's avatar
    Use debian packages from apt.logilab.fr · d6aefbe6310
    Philippe Pepiot authored
    We now have working repositories at:
    
    deb http://apt.logilab.fr {stretch,buster} {main,cubicweb-{3.25,3.26}}
    
    Use them instead of pip for base logilab/cubicweb images.
    
    * All images now have a apt looking for packages in /repo
    * Images for cubicweb 3.25 and 3.26 use packages from relevant repository
    * logilab/cubicweb:dev image use the new "buildpackage" image to build a
      package from latest public changeset of cubicweb.
    
    Packages to be installed differ given cubicweb and python versions, this is why
    we introduce a PACKAGES build ARG.
    
    We can now drop support for pip in "check-docker-updates.sh" script, since apt
    list --upgradable will detect new packages.
    4eaca20b