feat(pkginfo): upgrade cubicweb-blog to ">=1.15.0,<1.16.0"

Hello dear contributors,

This is an auto generated modification to help you improve the code base of logilab. If this commit is bad don't hesitate to close this MR and report it here https://forge.extranet.logilab.fr/cubicweb/cube-doctor/-/issues.

Kind regards,

Merge request reports