[deps] Upgrade CubicWeb to last Python 2 supported version

- The older versions are not supported anymore.
- apycot is not used anymore.
4 jobs for topic/default/cw-upgrade in 1 minute and 31 seconds (queued for 2 seconds)
Name Stage Failure
failed
py3 Test
=========================== short test summary info ============================
FAILED test/test_compound.py::CloneTC::test_clone_controller - TypeError: app...
================== 1 failed, 32 passed, 40 warnings in 34.96s ==================
ERROR: InvocationError for command /builds/cubicweb/cubes/compound/.tox/py3/bin/python -m pytest test (exited with code 1)
___________________________________ summary ____________________________________
ERROR: py3: commands failed
Running after_script
Uploading artifacts for failed job
ERROR: Job failed: command terminated with exit code 1