fix(deps): read_yaml_file() is in openapi-spec-validator version 0.4 but not 0.5

other option would be to adapt code to version 0.5 of the library

the lib is used in the code, but not in pkginfo, I am not sure where the dependency comes from.

Merge request reports