Commit f4e0970f authored by Julien Cristau's avatar Julien Cristau
Browse files

[pkg] stop running 2to3

We can run natively on python3.3+ now.
parent 9a4566938766
...@@ -38,13 +38,6 @@ except ImportError: ...@@ -38,13 +38,6 @@ except ImportError:
from distutils.command import install_lib from distutils.command import install_lib
USE_SETUPTOOLS = 0 USE_SETUPTOOLS = 0
try:
# python3
from distutils.command.build_py import build_py_2to3 as build_py
except ImportError:
# python2.x
from distutils.command.build_py import build_py
sys.modules.pop('__pkginfo__', None) sys.modules.pop('__pkginfo__', None)
# import optional features # import optional features
__pkginfo__ = __import__("__pkginfo__") __pkginfo__ = __import__("__pkginfo__")
...@@ -161,8 +154,7 @@ def install(**kwargs): ...@@ -161,8 +154,7 @@ def install(**kwargs):
scripts = ensure_scripts(scripts), scripts = ensure_scripts(scripts),
data_files = data_files, data_files = data_files,
ext_modules = ext_modules, ext_modules = ext_modules,
cmdclass = {'install_lib': MyInstallLib, cmdclass = {'install_lib': MyInstallLib},
'build_py': build_py},
**kwargs **kwargs
) )
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment