Commit 7a67a9c0 authored by Philippe Pepiot's avatar Philippe Pepiot
Browse files

Require python >= 3

Add python_requires and python3 only classifiers.
This avoid pip on python2 downloading a non python2 compatible package.
parent 725a972c7382
......@@ -38,3 +38,9 @@ install_requires = [
'lxml',
'html2text',
]
classifiers = [
"Programming Language :: Python",
"Programming Language :: Python :: 3",
"Programming Language :: Python :: 3 :: Only",
]
......@@ -76,7 +76,9 @@ def install(**kwargs):
data_files = data_files,
ext_modules = ext_modules,
namespace_packages = [subpackage_of],
python_requires='>=3',
install_requires = install_requires,
classifiers=pkginfo.get('classifiers', []),
**kwargs
)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment