chore(tox): add deb and pypi publish

11 jobs for topic/default/tox-deb in 2 minutes and 24 seconds (queued for 14 seconds)
Status Job ID Name Coverage
  Tests
passed black #109638

00:02:23

passed check-manifest #109637

00:01:54

passed flake8 #109636

00:00:44

passed mypy #109639

00:01:31

failed py3 #109635

00:00:21

 
  After Tests
skipped trigger-cubicweb-pipeline
skipped trigger-logilab-constraint-pipeline
skipped trigger-logilab-database-pipeline
skipped trigger-logilab-mtconverter-pipeline
skipped trigger-rql-pipeline
skipped trigger-yams-pipeline
 
Name Stage Failure
failed
py3 Tests
You should consider upgrading via the '/builds/open-source/logilab-common/.tox/py3/bin/python -m pip install --upgrade pip' command.

=================================== log end ====================================
ERROR: could not install deps [pytz, pytest == 5.4.1, git+https://github.com/Psycojoker/pytest-capture-deprecatedwarnings, git+https://github.com/psycojoker/pytest-capture-deprecatedwarnings]; v = InvocationError("/builds/open-source/logilab-common/.tox/py3/bin/python -m pip install pytz 'pytest == 5.4.1' git+https://github.com/Psycojoker/pytest-capture-deprecatedwarnings git+https://github.com/psycojoker/pytest-capture-deprecatedwarnings", 1)
___________________________________ summary ____________________________________
ERROR: py3: could not install deps [pytz, pytest == 5.4.1, git+https://github.com/Psycojoker/pytest-capture-deprecatedwarnings, git+https://github.com/psycojoker/pytest-capture-deprecatedwarnings]; v = InvocationError("/builds/open-source/logilab-common/.tox/py3/bin/python -m pip install pytz 'pytest == 5.4.1' git+https://github.com/Psycojoker/pytest-capture-deprecatedwarnings git+https://github.com/psycojoker/pytest-capture-deprecatedwarnings", 1)
Running after_script
Uploading artifacts for failed job
ERROR: Job failed: command terminated with exit code 1