Commit 4bf3873c authored by David Douard's avatar David Douard
Browse files

[pkg] pytz is only a setuptools test_require, not an install_requires (closes #281909)

parent 18d7d467614a
......@@ -42,8 +42,9 @@ include_dirs = [join('test', 'data')]
install_requires = [
'six >= 1.4.0',
'pytz',
]
test_require = ['pytz']
if sys.version_info < (2, 7):
install_requires.append('unittest2 >= 0.5.1')
if os.name == 'nt':
......
......@@ -54,6 +54,7 @@ subpackage_of = getattr(__pkginfo__, 'subpackage_of', None)
include_dirs = getattr(__pkginfo__, 'include_dirs', [])
ext_modules = getattr(__pkginfo__, 'ext_modules', None)
install_requires = getattr(__pkginfo__, 'install_requires', None)
test_require = getattr(__pkginfo__, 'test_require', None)
dependency_links = getattr(__pkginfo__, 'dependency_links', [])
classifiers = getattr(__pkginfo__, 'classifiers', [])
......@@ -153,6 +154,7 @@ def install(**kwargs):
packages = [modname] + get_packages(os.getcwd(), modname)
if USE_SETUPTOOLS and install_requires:
kwargs['install_requires'] = install_requires
kwargs['test_require'] = test_require
kwargs['dependency_links'] = dependency_links
kwargs['packages'] = packages
return setup(name = distname,
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment