Commit 75a15cbe authored by Noé Gaumont's avatar Noé Gaumont 🐙
Browse files

chore: check-docker-update

Before this patch, each patch version is build twice as the script output a package to be updgraded : cubicweb.
As the cubicweb package is mark as hold (see DockerFile), it will not be upgraded even with cache invalidation.

This patch intents to speed the build process
parent bd3d074fd533
......@@ -2,4 +2,6 @@
set -e
apt-get update >/dev/null
apt list --upgradable 2>/dev/null | grep "upgradable from" && exit 1 || exit 0
# Return true if at least one package EXCEPT cubicweb needs to be upgraded
# cubicweb package is mark as hold in order to have container for each version (minor and patch)
apt list --upgradable 2>/dev/null | grep "upgradable from" | grep --invert-match "cubicweb" && exit 1 || exit 0
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment