Commit e7a6c2de authored by Laurent Peuch's avatar Laurent Peuch
Browse files

chore: remove debian/fedora packaging

parent 7c14cce58224
Pipeline #68910 waiting for manual action with stages
in 2 minutes and 43 seconds
......@@ -10,7 +10,6 @@ recursive-include doc README *.png *py *rst Makefile
recursive-include test *.py
include test/data/bootstrap_cubes
prune debian
exclude Makefile
exclude *.spec
exclude dev-requirements.txt
......
# for el5, force use of python2.6
%if 0%{?el5}
%define python python26
%define __python /usr/bin/python2.6
%else
%define python python
%define __python /usr/bin/python
%endif
%{!?_python_sitelib: %define _python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
Name: cubicweb-squareui
Version: 1.1.2
Release: logilab.1%{?dist}
Summary: squareui component for the CubicWeb framework
Group: Applications/Internet
License: LGPL
Source0: cubicweb-squareui-%{version}.tar.gz
BuildArch: noarch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
BuildRequires: %{python} %{python}-setuptools
Requires: cubicweb >= 3.26.0
Requires: cubicweb-bootstrap >= 1.0.0
%description
squareui component for the CubicWeb framework
Main template that uses Bootstrap-compatible markup.
%prep
%setup -q -n cubicweb-squareui-%{version}
%if 0%{?el5}
# change the python version in shebangs
find . -name '*.py' -type f -print0 | xargs -0 sed -i '1,3s;^#!.*python.*$;#! /usr/bin/python2.6;'
%endif
%install
NO_SETUPTOOLS=1 %{__python} setup.py --quiet install --no-compile --prefix=%{_prefix} --root="$RPM_BUILD_ROOT"
%clean
rm -rf $RPM_BUILD_ROOT
%files
%defattr(-, root, root)
%{_prefix}/share/cubicweb*
%{_prefix}/lib/python*
cubicweb-squareui (1.1.3-1) unstable; urgency=medium
* new upstream release
-- Katia Saurfelt <katia.saurfelt@logilab.fr> Thu, 08 Oct 2020 23:05:22 +0200
cubicweb-squareui (1.1.2-1) unstable; urgency=medium
* new upstream release
-- Philippe Pepiot <philippe.pepiot@logilab.fr> Wed, 06 Mar 2019 15:01:57 +0100
cubicweb-squareui (1.1.1-1) unstable; urgency=medium
* new upstream release
-- Philippe Pepiot <philippe.pepiot@logilab.fr> Wed, 06 Mar 2019 09:59:57 +0100
cubicweb-squareui (1.1.0-1) unstable; urgency=medium
* New upstream release
-- Philippe Pepiot <philippe.pepiot@logilab.fr> Tue, 05 Mar 2019 15:00:23 +0100
cubicweb-squareui (1.0.3-2) unstable; urgency=medium
* Refresh debian packaging
-- Philippe Pepiot <philippe.pepiot@logilab.fr> Wed, 06 Dec 2017 13:57:01 +0100
cubicweb-squareui (1.0.3-1) unstable; urgency=medium
* New upstream release
-- Sylvain Thenault <sylvain.thenault@logilab.fr> Mon, 21 Nov 2016 14:25:50 +0100
cubicweb-squareui (1.0.2-1) unstable; urgency=medium
* New upstream release.
-- Rémi Cardona <remi.cardona@logilab.fr> Mon, 12 Oct 2015 10:17:29 +0200
cubicweb-squareui (1.0.1-1) unstable; urgency=medium
* New upstream release.
-- Rémi Cardona <remi.cardona@logilab.fr> Tue, 31 Mar 2015 12:12:44 +0200
cubicweb-squareui (1.0.0-1) unstable; urgency=medium
* New upstream release.
-- Rémi Cardona <remi.cardona@logilab.fr> Mon, 02 Feb 2015 12:03:35 +0100
cubicweb-squareui (0.3.8-1) unstable; urgency=medium
* New upstream release.
-- Rémi Cardona <remi.cardona@logilab.fr> Fri, 23 Jan 2015 11:56:01 +0100
cubicweb-squareui (0.3.7-1) unstable; urgency=low
* New upstream release.
-- Rémi Cardona <remi.cardona@logilab.fr> Mon, 03 Nov 2014 11:53:33 +0100
cubicweb-squareui (0.3.6-1) unstable; urgency=low
* New upstream release.
-- Rémi Cardona <remi.cardona@logilab.fr> Wed, 18 Jun 2014 16:44:35 +0200
cubicweb-squareui (0.3.5-1) unstable; urgency=low
* New upstream release. https://www.cubicweb.org/project/cubicweb-squareui/0.3.5
-- Katia Saurfelt <katia.saurfelt@logilab.fr> Mon, 16 Jun 2014 14:59:28 +0200
cubicweb-squareui (0.3.4-1) unstable; urgency=low
* New upstream release. https://www.cubicweb.org/project/cubicweb-squareui/0.3.4
-- Katia Saurfelt <katia.saurfelt@logilab.fr> Tue, 27 May 2014 15:18:30 +0200
cubicweb-squareui (0.3.3-1) unstable; urgency=low
* New upstream release. https://www.cubicweb.org/project/cubicweb-squareui/0.3.3
-- Katia Saurfelt <katia.saurfelt@logilab.fr> Fri, 11 Apr 2014 14:43:12 +0200
cubicweb-squareui (0.3.2-1) unstable; urgency=low
* New upstream release.
-- Rémi Cardona <remi.cardona@logilab.fr> Wed, 02 Apr 2014 17:11:33 +0200
cubicweb-squareui (0.3.1-1) unstable; urgency=low
* New upstream release.
-- Rémi Cardona <remi.cardona@logilab.fr> Wed, 19 Mar 2014 12:32:11 +0100
cubicweb-squareui (0.3.0-1) unstable; urgency=low
* New upstream release.
-- Rémi Cardona <remi.cardona@logilab.fr> Fri, 14 Mar 2014 11:35:43 +0100
cubicweb-squareui (0.2.1-1) unstable; urgency=low
* New upstream release
* Fix dependency on cubicweb-web instead of cubicweb-common
* Update dependency on cubicweb-bootstrap
-- David Douard <david.douard@logilab.fr> Thu, 30 Jan 2014 12:10:18 +0100
cubicweb-squareui (0.2.0-1) unstable; urgency=low
* New upstream release.
* Update dependency on bootstrap cube.
-- Rémi Cardona <remi.cardona@logilab.fr> Tue, 28 Jan 2014 10:30:13 +0100
cubicweb-squareui (0.1.0-1) unstable; urgency=low
* initial release
-- Rémi Cardona <remi.cardona@logilab.fr> Wed, 17 Jul 2013 12:18:25 +0200
Source: cubicweb-squareui
Section: web
Priority: optional
Maintainer: LOGILAB S.A. (Paris, FRANCE) <contact@logilab.fr>
Build-Depends: debhelper (>= 9),
python (>= 2.7),
dh-python,
python-setuptools,
python-six (>= 1.4.0),
cubicweb-common (>= 3.24.0),
cubicweb-bootstrap (>= 1.2.1),
Standards-Version: 4.3.0
X-Python-Version: >= 2.7
Package: cubicweb-squareui
Architecture: all
Depends:
${misc:Depends},
${python:Depends},
Description: data-centric user interface for cubicweb based on bootstrap
CubicWeb is a semantic web application framework.
.
data-centric user interface for cubicweb based on bootstrap
.
This package will install all the components you need to run the
cubicweb-squareui application (cube :)..
Upstream Author:
LOGILAB S.A. (Paris, FRANCE) <contact@logilab.fr>
Copyright:
Copyright (c) 2012-2020 LOGILAB S.A. (Paris, FRANCE).
http://www.logilab.fr -- mailto:contact@logilab.fr
#!/usr/bin/make -f
export PYBUILD_NAME = cubicweb-squareui
export PYBUILD_OPTION = --test-pytest
# Python 3.8 is broken in Debian unstable as of 2019-11-21
export PYBUILD_DISABLE_python3.8 = 1
%:
dh $@ --with python2,python3 --buildsystem=pybuild
extend-diff-ignore = "^([^/]*\.spec$)"
version=3
opts=uversionmangle=s/(rc|a|b|c)/~$1/ \
https://pypi.debian.net/cubicweb-squareui/cubicweb-squareui-(.+)\.(?:zip|tgz|tbz|txz|(?:tar\.(?:gz|bz2|xz)))
......@@ -49,24 +49,6 @@ commands =
twine check dist/*
twine upload --skip-existing dist/*
[testenv:deb-publish]
passenv = JENKINS_USER JENKINS_TOKEN
basepython = python3
skip_install = true
whitelist_externals =
rm
sh
hg
deps =
httpie
commands =
hg clean --all --dirs --files
rm -rf build dist .egg .egg-info
python3 setup.py sdist
sh -c "PACKAGE_NAME=$(python3 setup.py --name) && VERSION=$(python3 setup.py --version) && cd dist && tar xf $PACKAGE_NAME-$VERSION.tar.gz && cd $PACKAGE_NAME-$VERSION && cp -a {toxinidir}/debian . && mk-origtargz --rename ../$PACKAGE_NAME-$VERSION.tar.gz && dpkg-buildpackage -us -uc --no-check-builddeps --build=source "
sh -c "cd dist && dcmd zip latest.zip *.changes"
http -f POST https://{env:JENKINS_USER}:{env:JENKINS_TOKEN}@jenkins.intra.logilab.fr/job/pkg-from-dsc/buildWithParameters DIST=buster source.zip@dist/latest.zip REPO=buster PUBLISH=true
[testenv:yamllint]
skip_install = true
deps = yamllint
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment