Commit 276138a4 authored by Laurent Peuch's avatar Laurent Peuch
Browse files

chore: remove debian/fedora packaging

parent c5e253b3aedb
Pipeline #68955 failed with stages
in 2 minutes and 17 seconds
...@@ -9,7 +9,6 @@ include README.rst ...@@ -9,7 +9,6 @@ include README.rst
include cubicweb-skos.spec include cubicweb-skos.spec
prune cubicweb-skos.spec prune cubicweb-skos.spec
prune debian
exclude .gitlab-ci.yml exclude .gitlab-ci.yml
exclude .yamllint exclude .yamllint
exclude .cube-doctor.yml exclude .cube-doctor.yml
......
# for el5, force use of python2.6
%if 0%{?el5}
%define python python26
%define __python /usr/bin/python2.6
%else
%define python python
%define __python /usr/bin/python
%endif
%{!?_python_sitelib: %define _python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
Name: cubicweb-skos
Version: 1.3.0
Release: logilab.1%{?dist}
Summary: "SKOS implementation for cubicweb"
Group: Applications/Internet
License: LGPL
Source0: cubicweb-skos-%{version}.tar.gz
BuildArch: noarch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
BuildRequires: %{python} %{python}-setuptools
Requires: cubicweb >= 3.24.0
Requires: python-rdflib >= 4.1
%{?el6:Requires: python-redland}
%description
"SKOS implementation for cubicweb"
%prep
%setup -q -n cubicweb-skos-%{version}
%if 0%{?el5}
# change the python version in shebangs
find . -name '*.py' -type f -print0 | xargs -0 sed -i '1,3s;^#!.*python.*$;#! /usr/bin/python2.6;'
%endif
%install
%{__python} setup.py --quiet install --no-compile --prefix=%{_prefix} --root="$RPM_BUILD_ROOT"
%clean
rm -rf $RPM_BUILD_ROOT
%files
%defattr(-, root, root)
%{_python_sitelib}/*
cubicweb-skos (1.6.0-1) unstable; urgency=medium
* Add support for python3 packaging
* New upstream release
-- Philippe Pepiot <philippe.pepiot@logilab.fr> Thu, 28 Nov 2019 10:37:01 +0100
cubicweb-skos (1.5.0-1) unstable; urgency=medium
* New upstream release.
-- Denis Laxalde <denis.laxalde@logilab.fr> Wed, 31 Jul 2019 10:13:12 +0200
cubicweb-skos (1.3.0-1) unstable; urgency=medium
* New upstream release.
-- Denis Laxalde <denis.laxalde@logilab.fr> Mon, 19 Feb 2018 11:42:03 +0100
cubicweb-skos (1.2.1-1) unstable; urgency=medium
* New upstream release.
-- Denis Laxalde <denis.laxalde@logilab.fr> Fri, 26 Jan 2018 12:00:59 +0100
cubicweb-skos (1.2.0) unstable; urgency=medium
* New upstream release.
-- Denis Laxalde <denis.laxalde@logilab.fr> Mon, 18 Dec 2017 10:05:03 +0100
cubicweb-skos (1.1.3-1) unstable; urgency=medium
* New upstream release
-- Sylvain Thenault <sylvain.thenault@logilab.fr> Thu, 05 Oct 2017 10:48:21 +0200
cubicweb-skos (1.1.2-1) unstable; urgency=medium
* New upstream release
-- Sylvain Thenault <sylvain.thenault@logilab.fr> Wed, 10 May 2017 15:58:03 +0200
cubicweb-skos (1.1.1-1) unstable; urgency=medium
* New upstream release
-- Sylvain Thenault <sylvain.thenault@logilab.fr> Tue, 21 Mar 2017 11:00:54 +0100
cubicweb-skos (1.1.0-1) unstable; urgency=medium
* New upstream release
-- Sylvain Thenault <sylvain.thenault@logilab.fr> Fri, 27 Jan 2017 14:24:54 +0100
cubicweb-skos (1.0.0-1) unstable; urgency=medium
* New upstream release
-- Sylvain Thenault <sylvain.thenault@logilab.fr> Wed, 16 Nov 2016 10:42:27 +0100
cubicweb-skos (0.12.1-1) unstable; urgency=medium
* new upstream release
-- Sylvain Thenault <sylvain.thenault@logilab.fr> Tue, 18 Oct 2016 17:19:13 +0200
cubicweb-skos (0.12.0-1) unstable; urgency=medium
* new upstream release.
-- Denis Laxalde <denis.laxalde@logilab.fr> Thu, 23 Jun 2016 17:06:53 +0200
cubicweb-skos (0.11.0-1) unstable; urgency=medium
* New upstream release.
-- Denis Laxalde <denis.laxalde@logilab.fr> Thu, 26 May 2016 10:53:14 +0200
cubicweb-skos (0.10.0-1) unstable; urgency=medium
* New upstream release.
-- Sylvain Thenault <sylvain.thenault@logilab.fr> Wed, 11 May 2016 15:31:45 +0200
cubicweb-skos (0.9.0-1) unstable; urgency=medium
* New upstream release.
-- Denis Laxalde <denis.laxalde@logilab.fr> Fri, 12 Feb 2016 10:43:47 +0100
cubicweb-skos (0.8.0-1) unstable; urgency=medium
* new upstream release
-- Julien Cristau <julien.cristau@logilab.fr> Thu, 21 Jan 2016 15:15:09 +0100
cubicweb-skos (0.7.2-1) unstable; urgency=medium
* New upstream release.
-- Denis Laxalde <denis.laxalde@logilab.fr> Fri, 13 Nov 2015 10:36:35 +0100
cubicweb-skos (0.7.1-1) unstable; urgency=medium
* New upstream release.
-- Denis Laxalde <denis.laxalde@logilab.fr> Tue, 20 Oct 2015 11:50:07 +0200
cubicweb-skos (0.7.0-1) unstable; urgency=medium
* New upstream release.
-- Denis Laxalde <denis.laxalde@logilab.fr> Tue, 29 Sep 2015 11:02:11 +0200
cubicweb-skos (0.6.0-1) unstable; urgency=medium
* New upstream release.
-- Denis Laxalde <denis.laxalde@logilab.fr> Thu, 10 Sep 2015 11:47:37 +0200
cubicweb-skos (0.5.0-1) unstable; urgency=medium
* New upstream release.
-- Denis Laxalde <denis.laxalde@logilab.fr> Tue, 25 Aug 2015 15:48:28 +0200
cubicweb-skos (0.4.2-1) unstable; urgency=medium
* New upstream release.
-- Rémi Cardona <remi.cardona@logilab.fr> Thu, 23 Jul 2015 10:08:28 +0200
cubicweb-skos (0.4.1-1) unstable; urgency=medium
* New upstream release.
-- Rémi Cardona <remi.cardona@logilab.fr> Thu, 16 Jul 2015 19:14:17 +0200
cubicweb-skos (0.4.0-1) unstable; urgency=low
* New upstream release.
-- Denis Laxalde <denis.laxalde@logilab.fr> Tue, 16 Jun 2015 09:37:49 +0200
cubicweb-skos (0.3.0-1) unstable; urgency=medium
* new upstream release
-- Sylvain Thenault <sylvain.thenault@logilab.fr> Tue, 26 May 2015 14:47:40 +0200
cubicweb-skos (0.2.0-1) unstable; urgency=low
* New upstream release.
-- Denis Laxalde <denis.laxalde@logilab.fr> Wed, 29 Apr 2015 13:17:46 +0200
cubicweb-skos (0.1.0-1) unstable; urgency=low
* initial release
-- Denis Laxalde <denis.laxalde@logilab.fr> Tue, 31 Mar 2015 09:51:50 +0200
Source: cubicweb-skos
Section: web
Priority: optional
Maintainer: LOGILAB S.A. (Paris, FRANCE) <contact@logilab.fr>
Build-Depends: debhelper (>= 9),
dh-python,
python-all,
python-cubicweb,
python-cubicweb-relationwidget,
python-pytest,
python-rdflib,
python-setuptools,
python3-all,
python3-cubicweb,
python3-cubicweb-relationwidget,
python3-pytest,
python3-rdflib,
python3-setuptools,
Standards-Version: 4.3.0
X-Python-Version: >= 2.7
X-Python3-Version: >= 3.5
Package: python-cubicweb-skos
Architecture: all
Depends: ${misc:Depends}, ${python:Depends}
Recommends: python-rdflib (>= 4.1)
Breaks: cubicweb-skos (<< 1.6.0-1~)
Replaces: cubicweb-skos (<< 1.6.0-1~)
Description: SKOS implementation for cubicweb
CubicWeb is a semantic web application framework.
.
SKOS implementation for cubicweb
.
This package will install all the components you need to run an application
using the cubicweb-skos cube.
Package: python3-cubicweb-skos
Architecture: all
Depends: ${misc:Depends}, ${python3:Depends}
Recommends: python3-rdflib (>= 4.1)
Description: SKOS implementation for cubicweb
CubicWeb is a semantic web application framework.
.
SKOS implementation for cubicweb
.
This package will install all the components you need to run an application
using the cubicweb-skos cube.
Package: cubicweb-skos
Architecture: all
Section: oldlibs
Depends: python-cubicweb-skos, ${misc:Depends}
Description: transitional package
This is a transitional package. It can safely be removed.
Upstream Author:
LOGILAB S.A. (Paris, FRANCE) <contact@logilab.fr>
Copyright:
Copyright (c) 2015 LOGILAB S.A. (Paris, FRANCE).
http://www.logilab.fr -- mailto:contact@logilab.fr
#!/usr/bin/make -f
export PYBUILD_NAME = cubicweb-skos
# test_ccplugin requires PostgreSQL to be installed
# and thus is better tested using autopkgtest
export PYBUILD_TEST_ARGS = --ignore=test/test_ccplugin.py
# Python 3.8 is broken in Debian unstable as of 2019-11-21
export PYBUILD_DISABLE_python3.8 = 1
%:
dh $@ --with python2,python3 --buildsystem=pybuild
extend-diff-ignore = "^(.hg(/|ignore$|tags$))"
version=3
opts=uversionmangle=s/(rc|a|b|c)/~$1/ \
https://pypi.debian.net/cubicweb-skos/cubicweb-skos-(.+)\.(?:zip|tgz|tbz|txz|(?:tar\.(?:gz|bz2|xz)))
...@@ -45,24 +45,6 @@ commands = ...@@ -45,24 +45,6 @@ commands =
twine check dist/* twine check dist/*
twine upload --skip-existing dist/* twine upload --skip-existing dist/*
[testenv:deb-publish]
passenv = JENKINS_USER JENKINS_TOKEN
basepython = python3
skip_install = true
whitelist_externals =
rm
sh
hg
deps =
httpie
commands =
hg clean --all --dirs --files
rm -rf build dist .egg .egg-info
python3 setup.py sdist
sh -c "PACKAGE_NAME=$(python3 setup.py --name) && VERSION=$(python3 setup.py --version) && cd dist && tar xf $PACKAGE_NAME-$VERSION.tar.gz && cd $PACKAGE_NAME-$VERSION && cp -a {toxinidir}/debian . && mk-origtargz --rename ../$PACKAGE_NAME-$VERSION.tar.gz && dpkg-buildpackage -us -uc --no-check-builddeps --build=source "
sh -c "cd dist && dcmd zip latest.zip *.changes"
http -f POST https://{env:JENKINS_USER}:{env:JENKINS_TOKEN}@jenkins.intra.logilab.fr/job/pkg-from-dsc/buildWithParameters DIST=buster source.zip@dist/latest.zip REPO=buster PUBLISH=true
[testenv:yamllint] [testenv:yamllint]
skip_install = true skip_install = true
deps = yamllint deps = yamllint
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment