Commit c64bd6c6 authored by Laurent Peuch's avatar Laurent Peuch
Browse files

chore: remove debian/fedora packaging

parent dfe50b081724
Pipeline #68917 waiting for manual action with stages
in 7 minutes and 20 seconds
......@@ -9,7 +9,6 @@ include test/data/bootstrap_cubes test/data/*.xml test/data/*.xsd test/data/*.rn
include tox.ini dev-requirements.txt cubicweb_seda/makefile
exclude __pkginfo__.py
prune debian
exclude cubicweb-seda.spec
exclude .gitlab-ci.yml
include README.rst
......
# for el5, force use of python2.6
%if 0%{?el5}
%define python python26
%define __python /usr/bin/python2.6
%else
%define python python
%define __python /usr/bin/python
%endif
%{!?_python_sitelib: %define _python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
Name: cubicweb-seda
Version: 0.13.0
Release: logilab.1%{?dist}
Summary: Data Exchange Standard for Archival
Group: Applications/Internet
License: LGPL
Source0: cubicweb-seda-%{version}.tar.gz
BuildArch: noarch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
BuildRequires: %{python} %{python}-setuptools
Requires: cubicweb >= 3.25.3
Requires: cubicweb-eac
Requires: cubicweb-skos >= 1.3.0
Requires: cubicweb-compound >= 0.7
Requires: cubicweb-relationwidget >= 0.4l
Requires: cubicweb-squareui
Requires: %{python}-rdflib >= 4.1
Requires: %{python}-pyxst >= 0.2
Requires: %{python}-six >= 1.4.0
%description
Data Exchange Standard for Archival
%prep
%setup -q -n cubicweb-seda-%{version}
%if 0%{?el5}
# change the python version in shebangs
find . -name '*.py' -type f -print0 | xargs -0 sed -i '1,3s;^#!.*python.*$;#! /usr/bin/python2.6;'
%endif
%install
%{__python} setup.py install --no-compile --skip-build --root $RPM_BUILD_ROOT
%clean
rm -rf $RPM_BUILD_ROOT
%files
%defattr(-, root, root)
%{_python_sitelib}/*
cubicweb-seda (0.17.6-1) unstable; urgency=medium
* New upstream release
-- Noe Gaumont <noe.gaumont@logilab.fr> Wed, 25 Nov 2020 20:54:01 +0100
cubicweb-seda (0.13.0-1) unstable; urgency=medium
* New upstream release.
-- Sylvain Thenault <sylvain.thenault@logilab.fr> Tue, 19 Dec 2017 15:15:58 +0100
cubicweb-seda (0.12.0-1) unstable; urgency=medium
* New upstream release.
-- Sylvain Thenault <sylvain.thenault@logilab.fr> Tue, 07 Nov 2017 15:59:47 +0100
cubicweb-seda (0.11.5-1) unstable; urgency=medium
* New upstream release.
-- Sylvain Thenault <sylvain.thenault@logilab.fr> Thu, 19 Oct 2017 21:30:17 +0200
cubicweb-seda (0.11.4-1) unstable; urgency=medium
* New upstream release.
-- Denis Laxalde <denis.laxalde@logilab.fr> Thu, 19 Oct 2017 09:57:46 +0200
cubicweb-seda (0.11.3-1) unstable; urgency=medium
* New upstream release.
-- Denis Laxalde <denis.laxalde@logilab.fr> Tue, 17 Oct 2017 13:43:04 +0200
cubicweb-seda (0.11.2-1) unstable; urgency=medium
* New upstream release
-- Sylvain Thenault <sylvain.thenault@logilab.fr> Fri, 13 Oct 2017 17:53:59 +0200
cubicweb-seda (0.11.1-1) unstable; urgency=medium
* New upstream release
-- Sylvain Thenault <sylvain.thenault@logilab.fr> Fri, 13 Oct 2017 15:50:04 +0200
cubicweb-seda (0.11.0-1) unstable; urgency=medium
* New upstream release
-- Sylvain Thenault <sylvain.thenault@logilab.fr> Thu, 12 Oct 2017 17:07:15 +0200
cubicweb-seda (0.10.7-1) unstable; urgency=medium
* New upstream release
-- Sylvain Thenault <sylvain.thenault@logilab.fr> Fri, 01 Sep 2017 17:22:00 +0200
cubicweb-seda (0.10.6-1) unstable; urgency=medium
* New upstream release
-- Sylvain Thenault <sylvain.thenault@logilab.fr> Thu, 31 Aug 2017 11:07:59 +0200
cubicweb-seda (0.10.5-1) unstable; urgency=medium
* New upstream release
-- Sylvain Thenault <sylvain.thenault@logilab.fr> Thu, 20 Jul 2017 16:04:20 +0200
cubicweb-seda (0.10.4-1) unstable; urgency=medium
* New upstream release
-- Sylvain Thenault <sylvain.thenault@logilab.fr> Thu, 20 Jul 2017 15:43:33 +0200
cubicweb-seda (0.10.3-1) unstable; urgency=medium
* New upstream release
-- Sylvain Thenault <sylvain.thenault@logilab.fr> Tue, 06 Jun 2017 11:17:49 +0200
cubicweb-seda (0.10.2-1) unstable; urgency=medium
* New upstream release
-- Sylvain Thenault <sylvain.thenault@logilab.fr> Wed, 10 May 2017 15:26:05 +0200
cubicweb-seda (0.10.1-1) unstable; urgency=medium
* New upstream release
-- Sylvain Thenault <sylvain.thenault@logilab.fr> Thu, 13 Apr 2017 11:18:50 +0200
cubicweb-seda (0.10.0-1) unstable; urgency=medium
* New upstream release
-- Sylvain Thenault <sylvain.thenault@logilab.fr> Fri, 31 Mar 2017 09:43:13 +0200
cubicweb-seda (0.9.0-1) unstable; urgency=medium
* New upstream release
-- Sylvain Thenault <sylvain.thenault@logilab.fr> Tue, 21 Mar 2017 13:28:10 +0100
cubicweb-seda (0.8.0-1) unstable; urgency=medium
* New upstream release
-- Sylvain Thenault <sylvain.thenault@logilab.fr> Wed, 08 Mar 2017 06:31:40 +0100
cubicweb-seda (0.7.0-1) unstable; urgency=medium
* New upstream release
-- Sylvain Thenault <sylvain.thenault@logilab.fr> Thu, 23 Feb 2017 11:49:54 +0100
cubicweb-seda (0.6.0-1) unstable; urgency=medium
* New upstream relase
-- Sylvain Thenault <sylvain.thenault@logilab.fr> Mon, 30 Jan 2017 14:31:23 +0100
cubicweb-seda (0.5.1-1) unstable; urgency=medium
* New upstream release
-- Sylvain Thenault <sylvain.thenault@logilab.fr> Wed, 16 Nov 2016 11:45:09 +0100
cubicweb-seda (0.5.0-1) unstable; urgency=low
* initial release
-- Sylvain Thenault <sylvain.thenault@logilab.fr> Mon, 24 Oct 2016 10:33:39 +0200
Source: cubicweb-seda
Section: web
Priority: optional
Maintainer: LOGILAB S.A. (Paris, FRANCE) <contact@logilab.fr>
Build-Depends:
debhelper (>= 9),
python (>= 2.6.5),
python-setuptools,
Standards-Version: 3.9.3
X-Python-Version: >= 2.6
Package: cubicweb-seda
Architecture: all
Depends:
python-cubicweb (>= 3.25.3),
cubicweb-eac,
cubicweb-skos (>= 1.3.0),
cubicweb-compound (>= 0.7),
cubicweb-relationwidget (>= 0.4),
cubicweb-squareui,
python-pyxst (>= 0.2),
python-rdflib (>= 4.1),
python-six (>= 1.4.0),
${python:Depends},
${misc:Depends},
Description: Data Exchange Standard for Archival
CubicWeb is a semantic web application framework.
.
Data Exchange Standard for Archival
.
This package will install all the components you need to run the
cubicweb-seda application (cube :)..
Upstream Author:
LOGILAB S.A. (Paris, FRANCE) <contact@logilab.fr>
Copyright:
Copyright (c) 2016 LOGILAB S.A. (Paris, FRANCE).
http://www.logilab.fr -- mailto:contact@logilab.fr
#!/usr/bin/make -f
%:
dh $@ --with python2
......@@ -67,24 +67,6 @@ commands =
twine check dist/*
twine upload --skip-existing dist/*
[testenv:deb-publish]
passenv = JENKINS_USER JENKINS_TOKEN
basepython = python3
skip_install = true
whitelist_externals =
rm
sh
hg
deps =
httpie
commands =
hg clean --all --dirs --files
rm -rf build dist .egg .egg-info
python3 setup.py sdist
sh -c "PACKAGE_NAME=$(python3 setup.py --name) && VERSION=$(python3 setup.py --version) && cd dist && tar xf $PACKAGE_NAME-$VERSION.tar.gz && cd $PACKAGE_NAME-$VERSION && cp -a {toxinidir}/debian . && mk-origtargz --rename ../$PACKAGE_NAME-$VERSION.tar.gz && dpkg-buildpackage -us -uc --no-check-builddeps --build=source "
sh -c "cd dist && dcmd zip latest.zip *.changes"
http -f POST https://{env:JENKINS_USER}:{env:JENKINS_TOKEN}@jenkins.intra.logilab.fr/job/pkg-from-dsc/buildWithParameters DIST=buster source.zip@dist/latest.zip REPO=buster PUBLISH=true
[testenv:yamllint]
skip_install = true
deps = yamllint
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment