Commit 7617efaa authored by Nicola Spanti's avatar Nicola Spanti
Browse files

[pkg] Version 0.6.0

- Python 2 support removed.
- File cubicweb-rqlcontroller.spec seemed to be usefull only for
  Python 2.6, so we removed it.
- We use mainly Debian 10 "Buster" that ships python3.7 for
  python3, so we consider that we won't support previous versions
  anymore. This cube is maintained just a bit and users should
  upgrade, so it does not sound a problem to remove support for
  things that should be upgraded.
- With the same logic, the current last version of CubicWeb
  (3.27.3) is now required. In fact, the needed code in CubicWeb
  is not yet in a version, so it is not accurate, because the
  next one will be needed, but we would like not to wait to
  publish a new version of rqlcontroller.
parent c2f77ef03008
# for el5, force use of python2.6
%if 0%{?el5}
%define python python26
%define __python /usr/bin/python2.6
%else
%define python python
%define __python /usr/bin/python
%endif
%{!?_python_sitelib: %define _python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
Name: cubicweb-rqlcontroller
Version: 0.4.0
Release: logilab.1%{?dist}
Summary: restfull rql edition capabilities
Group: Applications/Internet
License: LGPL
Source0: cubicweb-rqlcontroller-%{version}.tar.gz
BuildArch: noarch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
BuildRequires: %{python} %{python}-setuptools
Requires: cubicweb >= 3.19.0
%description
restfull rql edition capabilities
%prep
%setup -q -n cubicweb-rqlcontroller-%{version}
%if 0%{?el5}
# change the python version in shebangs
find . -name '*.py' -type f -print0 | xargs -0 sed -i '1,3s;^#!.*python.*$;#! /usr/bin/python2.6;'
%endif
%install
NO_SETUPTOOLS=1 %{__python} setup.py --quiet install --no-compile --prefix=%{_prefix} --root="$RPM_BUILD_ROOT"
%clean
rm -rf $RPM_BUILD_ROOT
%files
%defattr(-, root, root)
%{_prefix}/share/cubicweb*
%{_prefix}/lib/python*
......@@ -4,7 +4,7 @@
modname = 'rqlcontroller'
distname = 'cubicweb-rqlcontroller'
numversion = (0, 5, 0)
numversion = (0, 6, 0)
version = '.'.join(str(num) for num in numversion)
license = 'LGPL'
......
cubicweb-rqlcontroller (0.6.0-1) unstable; urgency=medium
* Python 3 support only
* Fix for CubicWeb 3.27
* Upgrade requirements
* Add rqlio version 2.0
-- Nicola Spanti <nspanti@logilab.fr> Fri, 20 Mar 2020 16:32:11 +0100
cubicweb-rqlcontroller (0.4.0-1) unstable; urgency=medium
* New upstream release.
......@@ -19,7 +28,7 @@ cubicweb-rqlcontroller (0.3.1-1) unstable; urgency=medium
cubicweb-rqlcontroller (0.3.0-1) unstable; urgency=low
* new upstream release
* new upstream release
-- David Douard <david.douard@logilab.fr> Wed, 29 Oct 2014 22:10:45 +0100
......
......@@ -4,23 +4,21 @@ Priority: optional
Maintainer: LOGILAB S.A. (Paris, FRANCE) <contact@logilab.fr>
Build-Depends:
debhelper (>= 9),
python (>=2.7),
python (>= 3.7),
dh-python,
python-setuptools,
Standards-Version: 3.9.8
X-Python-Version: >= 2.7
X-Python-Version: >= 3.7
Package: cubicweb-rqlcontroller
Architecture: all
Depends:
python-cubicweb (>= 3.24),
python-cubicweb (>= 3.27.3),
python-six (>= 1.4),
${python:Depends},
${misc:Depends},
Description: restfull rql edition capabilities
CubicWeb is a semantic web application framework.
.
restfull rql edition capabilities
.
This package will install all the components you need to run the
cubicweb-rqlcontroller application (cube :)..
This package add a restfull API to query in RQL and install
what is needed for it.
......@@ -4,5 +4,5 @@ Upstream Author:
Copyright:
Copyright (c) 2013 LOGILAB S.A. (Paris, FRANCE).
http://www.logilab.fr -- mailto:contact@logilab.fr
Copyright (c) 2013-2020 LOGILAB S.A. (Paris, FRANCE).
https://www.logilab.fr -- mailto:contact@logilab.fr
#!/usr/bin/make -f
%:
dh $@ --with python2
dh $@ --with python3
[tox]
envlist = py27,py3,flake8
envlist = py3,flake8
[testenv]
deps =
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment