Commit da617a33 authored by David Douard's avatar David Douard
Browse files

[pkg] prepare 0.6.0

Remove dependency on python-crypto (crypto functions come from cubicweb), and
add a spec file for RPM packages.
parent 5d0b14bb8b0a
......@@ -4,7 +4,7 @@
modname = 'registration'
distname = 'cubicweb-registration'
numversion = (0, 5, 0)
numversion = (0, 6, 0)
version = '.'.join(str(num) for num in numversion)
license = 'LGPL'
......@@ -20,7 +20,6 @@ classifiers = [
]
__depends__ = {'cubicweb': '>= 3.19.0',
'pycrypto': None,
'Pillow': None,
}
......
# for el5, force use of python2.6
%if 0%{?el5}
%define python python26
%define __python /usr/bin/python2.6
%else
%define python python
%define __python /usr/bin/python
%endif
%{!?_python_sitelib: %define _python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
Name: cubicweb-registration
Version: 0.6.0
Release: logilab.1%{?dist}
Summary: public registration component for the CubicWeb framework
Group: Applications/Internet
License: LGPL
Source0: cubicweb-registration-%{version}.tar.gz
BuildArch: noarch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
BuildRequires: %{python} %{python}-setuptools
Requires: cubicweb >= 3.19.0
%description
This CubicWeb component provides a public registration feature (users
can register and create an account without the need for admin
intervention).
%prep
%setup -q -n cubicweb-registration-%{version}
%if 0%{?el5}
# change the python version in shebangs
find . -name '*.py' -type f -print0 | xargs -0 sed -i '1,3s;^#!.*python.*$;#! /usr/bin/python2.6;'
%endif
%install
NO_SETUPTOOLS=1 %{__python} setup.py --quiet install --no-compile --prefix=%{_prefix} --root="$RPM_BUILD_ROOT"
# remove generated .egg-info file
rm -rf $RPM_BUILD_ROOT/usr/lib/python*
%clean
rm -rf $RPM_BUILD_ROOT
%files
%defattr(-, root, root)
/*
......@@ -11,7 +11,6 @@ Package: cubicweb-registration
Architecture: all
Depends:
cubicweb-common (>= 3.19.0),
python-crypto,
python-imaging,
${python:Depends},
${misc:Depends},
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment