Commit bed4978a authored by Nicola Spanti's avatar Nicola Spanti
Browse files

[deps] Upgrade to the last version of CW supporting Py2

Why? Because we do not support anymore older versions (and so
don't test on its). Python 2 is currently kept for a project
client, but it will not last, to ease maintenance and encourage
to upgrade to have new features.
parent cfde733554ea
Pipeline #28458 passed with stage
in 2 minutes and 53 seconds
......@@ -2,7 +2,7 @@
"""cubicweb-postgis application packaging information"""
modname = 'postgis'
distname = 'cubicweb-postgis'
distname = 'cubicweb-%s' % modname
numversion = (0, 7, 0)
version = '.'.join(str(num) for num in numversion)
......@@ -11,10 +11,10 @@ license = 'LGPL'
author = 'LOGILAB S.A. (Paris, FRANCE)'
author_email = 'contact@logilab.fr'
description = 'Test for postgis'
web = 'http://www.cubicweb.org/project/%s' % distname
web = 'https://www.cubicweb.org/project/%s' % distname
__depends__ = {
'cubicweb': '>= 3.24.0',
'cubicweb': '>= 3.26.19',
}
__recommends__ = {}
......@@ -22,6 +22,7 @@ classifiers = [
'Environment :: Web Environment',
'Framework :: CubicWeb',
'Programming Language :: Python',
'Programming Language :: Python :: 2',
'Programming Language :: Python :: 3',
'Programming Language :: JavaScript',
'Topic :: Scientific/Engineering :: GIS',
......
......@@ -2,7 +2,7 @@
# pylint: disable=W0142,W0403,W0404,W0613,W0622,W0622,W0704,R0904,C0103,E0611
#
# copyright 2003-2016 LOGILAB S.A. (Paris, FRANCE), all rights reserved.
# contact http://www.logilab.fr/ -- mailto:contact@logilab.fr
# contact https://www.logilab.fr/ -- mailto:contact@logilab.fr
#
# This file is part of a cubicweb-postgis.
#
......@@ -17,7 +17,7 @@
# details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with CubicWeb. If not, see <http://www.gnu.org/licenses/>.
# along with CubicWeb. If not, see <https://www.gnu.org/licenses/>.
"""cubicweb_postgis setup module using data from
cubicweb_postgis/__pkginfo__.py file
"""
......@@ -79,4 +79,5 @@ setup(
],
},
zip_safe=False,
python_requires='>=2.7',
)
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment