feat(pkginfo): upgrade cubicweb-oauth2 to ">=0.3.0,<0.4.0"

6 jobs for topic/default/upgrade-cubicweb-oauth2-to-0.3.0-0.4.0 in 5 minutes and 36 seconds (queued for 21 seconds)
Status Job ID Name Coverage
  Lint
passed #157804
yamllint

00:00:17

 
  Tests
failed #157808
black

00:00:35

passed #157805
check-manifest

00:00:27

passed #157806
flake8

00:00:25

failed #157809
mypy

00:01:23

passed #157807
py3

00:05:17

 
Name Stage Failure
failed
mypy Tests
cubicweb_intranet/migration/0.13.0_Any.py:17: error: Name 'drop_relation_type' is not defined
cubicweb_intranet/migration/0.11.0_Any.py:1: error: Name 'add_relation_definition' is not defined
Found 33 errors in 12 files (checked 15 source files)
ERROR: InvocationError for command /builds/cubicweb/cubes/intranet/.tox/mypy/bin/mypy --ignore-missing-imports cubicweb_intranet (exited with code 1)
___________________________________ summary ____________________________________
ERROR: mypy: commands failed
Running after_script
Uploading artifacts for failed job
ERROR: Job failed: command terminated with exit code 1
failed
black Tests
would reformat /builds/cubicweb/cubes/intranet/setup.py
Oh no! 💥 💔 💥
15 files would be reformatted, 2 files would be left unchanged.
ERROR: InvocationError for command /builds/cubicweb/cubes/intranet/.tox/black/bin/black --check . (exited with code 1)
___________________________________ summary ____________________________________
ERROR: black: commands failed
Running after_script
Uploading artifacts for failed job
ERROR: Job failed: command terminated with exit code 1