__pkginfo__.py 1.31 KB
Newer Older
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
# pylint: disable-msg=W0622
"""cubicweb-intranet application packaging information"""

modname = "intranet"
distname = "cubicweb-intranet"

numversion = (2, 0, 0)
version = ".".join(str(num) for num in numversion)

license = "LGPL"
author = "Logilab"
author_email = "contact@logilab.fr"
description = "an intranet built on the CubicWeb framework"
web = "http://cubicweb.org/project/cubicweb-intranet"
classifiers = [
    "Environment :: Web Environment",
    "Framework :: CubicWeb",
    "Programming Language :: Python",
    "Programming Language :: JavaScript",
    "Programming Language :: Python :: 3",
    "Programming Language :: Python :: 3 :: Only",
]

__depends__ = {
    "cubicweb[pyramid]": ">= 3.28.1",
26
    "cubicweb-blog": ">=1.14.0,<1.15.0",
27
    "cubicweb-book": ">=0.8.0,<0.9.0",
28
    "cubicweb-card": ">=1.1.0,<1.2.0",
29
    "cubicweb-link": ">=1.9.0,<1.10.0",
30
    "cubicweb-file": ">=2.3.0,<2.4.0",
31
    "cubicweb-folder": ">=2.1.0,<2.2.0",
32
33
34
35
36
37
38
39
40
41
42
43
44
    "cubicweb-tag": None,
    "cubicweb-comment": ">= 1.14.1",
    "cubicweb-task": None,
    "cubicweb-event": None,
    "cubicweb-rqlcontroller": None,
    "cubicweb-signedrequest": ">= 0.5.1",
    "cubicweb-sentry": None,
    "cubicweb-preview": None,
    "cubicweb-localperms": None,
    "cubicweb-jsonschema": None,
    "cubicweb-searchui": None,
    "cubicweb-bootstrap": None,
}