feat(pkginfo): auto-upgrade all dependencies at once

* cubicweb[pyramid] to >=3.33.0,<3.34.0
* reportlab to >=3.6.0,<3.7.0
6 jobs for !36 with topic/default/upgrade-all-72176c21aacb1a39d7fca8faf95db6b4b96e3ea6 in 5 minutes and 41 seconds (queued for 1 minute and 57 seconds)
latest detached
Status Job ID Name Coverage
  Lint
passed black #351002

00:00:28

passed check-manifest #351003

00:00:26

passed flake8 #351004

00:00:31

failed mypy #351005
allowed to fail

00:00:16

 
  Tests
passed py3 #351006

00:03:15

 
  Release
passed image_build #351007

00:01:10

 
Name Stage Failure
failed
mypy Lint
Installing collected packages: zipp, typing-extensions, importlib-metadata, six, pyparsing, platformdirs, filelock, distlib, backports.entry-points-selectable, virtualenv, toml, py, pluggy, packaging, tox
WARNING: Running pip as the 'root' user can result in broken permissions and conflicting behaviour with the system package manager. It is recommended to use a virtual environment instead: https://pip.pypa.io/warnings/venv
Successfully installed backports.entry-points-selectable-1.1.0 distlib-0.3.2 filelock-3.0.12 importlib-metadata-4.6.3 packaging-21.0 platformdirs-2.2.0 pluggy-0.13.1 py-1.10.0 pyparsing-2.4.7 six-1.16.0 toml-0.10.2 tox-3.24.1 typing-extensions-3.10.0.0 virtualenv-20.7.0 zipp-3.5.0
WARNING: You are using pip version 21.2.1; however, version 21.2.2 is available.
You should consider upgrading via the '/usr/local/bin/python -m pip install --upgrade pip' command.
$ tox -e mypy
ERROR: unknown environment 'mypy'
Cleaning up file based variables
ERROR: Job failed: command terminated with exit code 1