Commit 703db4a6 authored by Laurent Peuch's avatar Laurent Peuch
Browse files

fix(remove-extra-requirements-pyramid): improve version of the script

It's still not perfect and finished and we'll need to to port it to python.
parent 0ad27030157e
Pipeline #82369 failed with stage
in 20 seconds
......@@ -2,9 +2,16 @@
set -x
sed 's/cubicweb\[pyramid\]/cubicweb/g' -i setup.py || true
sed 's/cubicweb\[pyramid\]/cubicweb/g' -i __pkginfo__.py || true
sed 's/cubicweb\[pyramid\]/cubicweb/g' -i */__pkginfo__.py || true
sed_expression_simple='s/cubicweb\[pyramid\]/cubicweb/g'
sed_expression='s/cubicweb\[\(.*\)pyramid,\?\(.*\)\]/cubicweb[\1\2]/g'
sed "$sed_expression_simple" -i setup.py || true
sed "$sed_expression" -i setup.py || true
[ ! -h __pkginfo__.py ] && sed "$sed_expression_simple" -i __pkginfo__.py || true
[ ! -h __pkginfo__.py ] && sed "$sed_expression" -i __pkginfo__.py || true
sed "$sed_expression_simple" -i */__pkginfo__.py || true
sed "$sed_expression" -i */__pkginfo__.py || true
# GITLAB_TOKEN=$(cat token) cube-doctor run-script \
# -s scripts/remove-extra-requirements-pyramid.sh
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment